悄悄的就必须用 XCode 5.1.1 上传了!

前天上架一个App,在 Waiting for Upload ,XCode Validate 的时候总是报错不通过,错误信息如下:

This Bundle is invalid.New apps and app updates submitted to the App Store must be built with public

字面完全看出任何信息,然后一搜索有说是 XCode 版本过低,大都是说从2014年2月1日开始所有App提交必须用XCode5了。但我的Xcode版本是5.1啊,最后无情百度给了我个CocoaChina的链接,有人说到现在上传应用必须是XCode 5.1.1了,还给出了官方新闻的链接。一看果然是,14年4月15号发的news,我16号开始提交的,顿时哭的那一个伤心啊…

Build Your Apps With Xcode 5.1.1

最可恨的是为什么不在错误信息里说明一点,就一个 “with public” 我能知道什么啊…

在这里用篇博客记录下来一是给自己留个纪念,二是如果有和我相同遭遇的朋友看到可以少废点时间。